[webkit-dev] SharedWorkers alternate design
mjs at apple.com
Thu May 28 16:20:47 PDT 2009
On May 28, 2009, at 3:14 PM, Michael Nordman wrote:
> Doesn't sound like we have a consensus on naming yet? Many of the
> suggestions are workable to me.
> FooClient | FooFrontend | FooIntf | FooConsumer
> FooService | FooBackend | FooImpl | FooProvider
> I have a patch that is employing FooFrontend + FooBackend naming...
> i'd be happy to change to something else... or not.
> I don't like 'proxy' to indicate one side or the other, because as
> Jeremy said it doesn't indicate which side, there are proxies on both
> sides to communicate with the other.
> My top two picks...
> 1) FooFrontend + FooBackend
> 2) FooClient + FooService
Can you think of a more specific way to describe the reationship than
"front" and "back" or "client" and "service"? Does one of the Gang of
Four Design Patterns apply? That can be a good resource for clear ways
to describe class relationships, even fairly abstract ones.
More information about the webkit-dev