[webkit-dev] SharedWorkers alternate design
jorlow at chromium.org
Thu May 28 15:50:12 PDT 2009
I think it was pretty clear from the thread that X and XClient is prefered
when you have 2 way communication. In some cases, you have X which is the
interface, XImpl which is the implementation, and XProxy for a proxy.
But yeah....I think Foo and FooClient is the way to go with Impl and Proxy
if you need to have 2 versions of each (which I think you do).
On Thu, May 28, 2009 at 3:14 PM, Michael Nordman <michaeln at google.com>wrote:
> Doesn't sound like we have a consensus on naming yet? Many of the
> suggestions are workable to me.
> FooClient | FooFrontend | FooIntf | FooConsumer
> FooService | FooBackend | FooImpl | FooProvider
> I have a patch that is employing FooFrontend + FooBackend naming...
> i'd be happy to change to something else... or not.
> I don't like 'proxy' to indicate one side or the other, because as
> Jeremy said it doesn't indicate which side, there are proxies on both
> sides to communicate with the other.
> My top two picks...
> 1) FooFrontend + FooBackend
> 2) FooClient + FooService
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev