[webkit-dev] SharedWorkers alternate design
michaeln at google.com
Thu May 28 15:14:29 PDT 2009
Doesn't sound like we have a consensus on naming yet? Many of the
suggestions are workable to me.
FooClient | FooFrontend | FooIntf | FooConsumer
FooService | FooBackend | FooImpl | FooProvider
I have a patch that is employing FooFrontend + FooBackend naming...
i'd be happy to change to something else... or not.
I don't like 'proxy' to indicate one side or the other, because as
Jeremy said it doesn't indicate which side, there are proxies on both
sides to communicate with the other.
My top two picks...
1) FooFrontend + FooBackend
2) FooClient + FooService
More information about the webkit-dev