[webkit-dev] renaming ASSERT macro

Jörg Bornemann joerg.bornemann at trolltech.com
Fri Jun 27 01:50:36 PDT 2008

Darin Adler wrote:

> Then lets add this to Assertion.h:
>     #if PLATFORM(WINCE) // or whatever is the right if
>     #include <windows.h>
>     #endif
> I'd prefer this to a global change to the entire WebKit project.

You really want to include <windows.h> in every single webkit file?
Well, this is a small change but also a very bad idea. Not because of 
compilation time, but because of the crappy Windows headers which define 
*a* *lot* of global stuff. E.g. the XSLT parser of WebKit won't build 
because there's a "#define ERROR <somenumber>" which breaks an enum 
definition. Or think of the famous MIN / MAX definitions, which drive 
every crossplatform developer insane.
   Assume, that we do this global include. Every Windows developer who 
wants to use WebKit must take care to avoid every possible name clash in 
their projects, which might be problematic, if one has to use 3rd party 
   I'd rather live with mixed ASSERTs and compiler warnings...

Best Regards,


More information about the webkit-dev mailing list