[webkit-dev] renaming ASSERT macro
darin at apple.com
Fri Jun 27 09:20:14 PDT 2008
On Jun 27, 2008, at 1:50 AM, Jörg Bornemann wrote:
> Well, this is a small change but also a very bad idea. Not because of
> compilation time, but because of the crappy Windows headers which
> *a* *lot* of global stuff. E.g. the XSLT parser of WebKit won't build
> because there's a "#define ERROR <somenumber>" which breaks an enum
> definition. Or think of the famous MIN / MAX definitions, which drive
> every crossplatform developer insane.
OK. Lets #undef those things.
More information about the webkit-dev