[webkit-dev] renaming ASSERT macro
joerg.bornemann at trolltech.com
Thu Jun 26 05:16:48 PDT 2008
to something that doesn't clash with the Win32 ASSERT macro.
There's already a hack that undefines this macro before the definition
in Assertion.h. This is an easy work-around but on Windows CE (where I'm
developing on) the situation is worse: ASSERT gets defined in windows.h
That means ATM that I have to make sure to always include <windows.h>
_before_ Assertion.h. Otherwise I come up with a mix of Windows
assertions and WebKit assertions, not to speak of the warning of an
already defined ASSERT...
As you can see in Assertions.h, renaming ASSERT is not completely my idea:
/* FIXME: Change to use something other than ASSERT to avoid this
conflict with win32. */
So, what do you think about this?
What would be a proper name for the macro? WKASSERT?
More information about the webkit-dev