[webkit-dev] renaming some WebCore, too

Darin Adler darin at apple.com
Sun Jun 15 23:46:21 PDT 2008

On Jun 13, 2008, at 4:26 PM, Darin Adler wrote:

> As with the JavaScriptCore renames, I have some WebCore renames I'd  
> like to do.

I completed most of the renaming mentioned here, with four exceptions:

> Take the K out of KURL.

I haven't done this one yet. Maciej slightly prefers ParsedURL, to  
emphasize that the URL is different from a String because it's parsed  
into pieces, over the proposed name URL.

I remember that I preferred ParsedURL at one point too, and Anders and  
some others talked me into thinking URL was better. I can't remember  
the arguments on both sides.

Until this is resolved to my satisfaction, I'll leave it as KURL.

> Change the renderer for the viewport to be named RenderViewport  
> instead of RenderView.
>     "RenderView" => "RenderViewport",

Didn't do this one yet, in part because I don't know if Hyatt thinks  
it's a good idea.

> Unify the names of ThreadSafeShared and RefCounted.
>     "ThreadSafeShared" => "ThreadSafeRefCounted",

Didn't do this one yet. I'm not a big fan of the term "Safe" in names  
like this, so it might be worth thinking more on what would be a  
better name.

> Start using the term "bridged object" instead of "runtime object"  
> for things that we bridge to JavaScript.

Didn't do this one yet, because I'm not sure the proposed names are  

     -- Darin

More information about the webkit-dev mailing list