[webkit-dev] renaming some WebCore, too

Darin Adler darin at apple.com
Sat Jun 14 23:14:52 PDT 2008

On Jun 13, 2008, at 4:26 PM, Darin Adler wrote:

> Use a less confusing name for the base class for all form controls.
> It's hard to understand how HTMLGenericFormElement (a control within a
> form) differs from HTMLFormElement (the form itself).
>     "HTMLGenericFormElement" => "HTMLFormControlElement",
>     "HTMLGenericFormElement_h" => "HTMLFormControlElement_h",

I got started on renames by doing this one.

> Retire obsolete "domString" nomenclature.
>     "domString" => "string",

Turns out this one was already done a while ago.

     -- Darin

More information about the webkit-dev mailing list