[webkit-dev] renaming some things in JavaScriptCore

Maciej Stachowiak mjs at apple.com
Sat Jun 14 22:36:41 PDT 2008

On Jun 14, 2008, at 10:26 PM, Darin Adler wrote:

> On Jun 13, 2008, at 3:51 PM, Geoffrey Garen wrote:
>>> Cut down on confusing uses of "Object" and "Imp".
>> Should we add the JS prefix to these, too?
> I'm not sure.
> If we want to add a JS prefix to all these names, then there'd be even
> more names to change because I left some closely related names alone,
> and they'd need the JS prefixes.
> A while back, I added JS to "Value" and "Object" because even with a
> namespace, the names "Value" and "Object" didn't seem clearly enough
> to be "JavaScript language value". I think that applies to many of
> these other types too. It's hard to say. Maybe we do indeed want JS
> prefixes on all of these.

I would prefer if we keep a JS prefix only on the objects that seem  
like very generic names otherwise. Perhaps we could just always  
reference these with namespace-qualified names, if the namespace  
prefix is short enough. So JSC::Object instead of JSObject. But I am  
not sure I like that.

Another thought that came up is that perhaps we should change our  
namespace from KJS to JSC.


More information about the webkit-dev mailing list