[webkit-dev] renaming some things in JavaScriptCore

Darin Adler darin at apple.com
Sat Jun 14 22:39:55 PDT 2008

On Jun 14, 2008, at 10:36 PM, Maciej Stachowiak wrote:

> I would prefer if we keep a JS prefix only on the objects that seem  
> like very generic names otherwise.

Makes sense.

Given that rule of thumb, what do you think of these:

     "GetterSetterImp" => "JSGetterSetter",
     "NumberImp" => "JSNumberCell",
     "StringImp" => "JSString",

     "ArrayInstance" => "JSArray",
     "FunctionImp" => "JSFunction",

Do all of those deserve the JS prefix? Maybe the first three and not  
the last two?

> Another thought that came up is that perhaps we should change our  
> namespace from KJS to JSC.

I like the idea. But I'm not crazy about the three WebKit namespaces  
being WTF, JSC, and WebCore. One of these things is not like the others!

     -- Darin

More information about the webkit-dev mailing list