[webkit-dev] renaming some things in JavaScriptCore

Darin Adler darin at apple.com
Sat Jun 14 22:26:37 PDT 2008

On Jun 13, 2008, at 3:51 PM, Geoffrey Garen wrote:

>> Cut down on confusing uses of "Object" and "Imp".
> Should we add the JS prefix to these, too?

I'm not sure.

If we want to add a JS prefix to all these names, then there'd be even  
more names to change because I left some closely related names alone,  
and they'd need the JS prefixes.

A while back, I added JS to "Value" and "Object" because even with a  
namespace, the names "Value" and "Object" didn't seem clearly enough  
to be "JavaScript language value". I think that applies to many of  
these other types too. It's hard to say. Maybe we do indeed want JS  
prefixes on all of these.

     -- Darin

More information about the webkit-dev mailing list