[webkit-dev] cygwin gives Bad interpreter No such file or directory

David Kilzer ddkilzer at webkit.org
Sat Dec 6 18:43:27 PST 2008

That means you don't have Perl installed with Cygwin.  Try repeating the installation step(s) on webkit.org for installing Cygwin (Step 3 under Windows):



From: Andrew Adcock <andynsonya at comcast.net>
To: David D. Kilzer <ddkilzer at kilzer.net>
Cc: webkit-dev at lists.webkit.org
Sent: Saturday, December 6, 2008 2:15:58 PM
Subject: Re: [webkit-dev] cygwin gives Bad interpreter No such file or directory

when I run those I get:

bash: perl: command not found

which: no perl in (/usr/local/bin:/usr/bin:/usr/X11R6/bin:/cygdrive/c/Windows/system32:/cygdrive/c/Windows:/cygdrive/c/Windows/System32/Wben:/cygdrive/c/Program Files/CyberLink/Power2Go/: cygdrive/c/Program Files/QuickTime/QTSystem/:/cygdrive/c/Program Files/Microsoft SQL Server/90/Tools/binn/:cygdrive/c/Program Files/SlikSvn/bin/)

David D. Kilzer wrote:
> Run "perl --version" to see which build/version of Perl you're using, and "which perl" to see where in your path the perl.exe binary is located.
> Dave
> ------------------------------------------------------------------------
> *From:* Andrew Adcock <andynsonya at comcast.net>
> *To:* Darren VanBuren <onekopaka at gmail.com>
> *Cc:* webkit-dev at lists.webkit.org
> *Sent:* Saturday, December 6, 2008 1:30:24 PM
> *Subject:* Re: [webkit-dev] cygwin gives Bad interpreter No such file or directory
> I installed the downloader available through http://webkit.org/building/tools.html
> so I am not sure if it came with Perl  - is there a way that I can check?
> Darren VanBuren wrote:
> >
> > On Dec 6, 2008, at 12:07 PM, Andrew Adcock wrote:
> >
> >> Hello all,
> >>
> >> I tried finding a solution as best I could but nothing came up after several hours.
> >> My problem is that I am trying to build webkit - I know that I have everything installed (Checked 3 or 4 times) and I know the file is where I would expect because when I type:
> >> find WebKit/WebKitTools/Scripts/build-webkit  its there plain as day.
> >>
> >> So what am I missing?
> >>
> >> I am using windows Vista and Visual C++ 2005 Express Edition
> >>
> >> Thanks,
> >> Andy
webkit-dev mailing list
webkit-dev at lists.webkit.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20081206/03b39e13/attachment.html>

More information about the webkit-dev mailing list