[wpe-webkit] AArch64 builds in AUR

Adrian Perez de Castro aperez at igalia.com
Wed Mar 27 08:29:35 PDT 2019


On Fri, 22 Mar 2019 21:23:59 +0100, Andrea Giammarchi <andrea.giammarchi at gmail.com> wrote:
> Last update for the Raspberry Pi 3 and Arch Linux
>    - the touch screen works but it needs linux-aarch64-raspberrypi-bin
>    which actually gave me some other issue (but it works in general)

Nice to know that it worked in the end  \o/

The notes about libinput I wrote in the other e-mail still apply in case
you need to troubleshoot other input hardware.

>    - most CSS, WebGL, 2D canvas demos are fine, even without overclocking
>    the pi, and either at 720p or 480p (touch screen resolution)

Cool :)

> What still doesn't feel right ...
>    - I've seen this demo running on a video, no way it works here
>    http://www.emerveille.fr/lab/helloracer/index.html ... is there any
>    remote way to debug the WPE console / errors?

You can make Cog write the JS console messages to the standard error with:

  % cog --enable-write-console-messages-to-stdout=true ...

Another option is using the remote inspector. Define the environment variable
“WEBKIT_INSPECTOR_SERVER=ipadddress:port” before launching Cog with the
“--enable-developer-extras=true” command line flag, and then from another
computer launch Epiphany (or some other WebKitGTK or WPE based browser) with
an “inspector://” URI:

  % epiphany inspector://ipaddress:port

Then you will have a Web inspector in the computer to interact and analyze
the Web content loaded by Cog in the Raspberry Pi.

>    - this demo says that something is missing ... as if the WebGL version I
>    am using is not updated enough: http://madebyevan.com/webgl-water/

WebKit supports WebGL 1.0, which is based on OpenGL ES 2.0; but WebGL 2.0 is
is not yet supported. From what I can see, this demo requires WebGL 1.0 so
that's good, but it uses the OES_texture_float and OES_standard_derivatives
extensions. You can check whether these two are supported (and other infos
about the WebGL implementation) using this page:


Which extensions are supported depends on the GPU driver. As far as I know
the vc4 driver does not support them and that is most likely the reason why
it does not work.

>    - there is no way I can run the pasta demo at the same speed shown in
>    this post:
>    https://medium.com/@decrocksam/building-wpe-webkit-for-raspberry-pi-3-cdbd7b5cb362

Interestingly enough, the pasta demo does not work for me here on one of my
laptops with an Intel GPU. No idea why, though: it loads, a frame is shown and
then the image stays static (no more further frames rendered). I poked a bit
at it but couldn't see any obvious reason why it won't animate.

> Accordingly, I wonder if I'm still missing something ... like building
> Cairo with OpenGL instead of GLESv2 ... or building something else with
> OpenGL or GLEv2 enabled (mesa? ... FAIK video core is already mainstream
> supported though)

Yes, Mesa has had the vc4 driver for VideoCore in the upstream repository
for years, you shouldn't need anything else.

> P.S. I'm happy regardless with the result 'cause it's still the best kiosk
> I could imagine for a Pi so far 👋

Glad to hear^W read that! :D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.webkit.org/pipermail/webkit-wpe/attachments/20190327/fa04490f/attachment.bin>

More information about the webkit-wpe mailing list