[Webkit-unassigned] [Bug 235459] WebKit fails to build - error: 'webrtc/rtc_base/network.h' file not found

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 21 16:45:01 PST 2022


Mark Lam <mark.lam at apple.com> changed:

           What    |Removed                     |Added
                 CC|                            |mark.lam at apple.com
 Attachment #449705|review?                     |review+
              Flags|                            |

--- Comment #3 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 449705
  --> https://bugs.webkit.org/attachment.cgi?id=449705

View in context: https://bugs.webkit.org/attachment.cgi?id=449705&action=review

I'm not super familiar with the plumbing of all the settings variables, but this patch LGTM.

> Source/ThirdParty/libwebrtc/Scripts/create-symlink-to-altroot.sh:27
> +    RELATIVE_PATH_FROM_SYMLINK_TO_ROOT=$(echo "${PUBLIC_FOLDER_PREFIX}" | sed -E -e "s/\/[a-zA-Z0-9_]+/..\//g" -e "s/\/$//")

Why is this "s/\/$//" needed?

> Source/ThirdParty/libwebrtc/Scripts/create-symlink-to-altroot.sh:28

nit: call this SYMLINK_TARGET instead?

> Source/ThirdParty/libwebrtc/Scripts/create-symlink-to-altroot.sh:52
> +        if [[ ! -d ${SYSTEM_PUBLIC_HEADER_PREFIX} ]]; then
> +            mkdir -p ${SYSTEM_PUBLIC_HEADER_PREFIX}
> +        fi

Can't you do this just once outside of the for loop?  The only difference is that moving this out would create this directory even if HEADER_FOLDER_LIST is empty.  But we know it'll never be empty, right?

> Source/ThirdParty/libwebrtc/Scripts/create-symlink-to-altroot.sh:64
> +        if [[ ! -d ${SYSTEM_PUBLIC_LIBRARY_PREFIX} ]]; then
> +            mkdir -p ${SYSTEM_PUBLIC_LIBRARY_PREFIX}
> +        fi

Ditto.  Do this outside the for loop?

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220122/b779a74f/attachment.htm>

More information about the webkit-unassigned mailing list