[Webkit-unassigned] [Bug 191627] [css-grid] Incorrect track sizing when using relative sized items in 'auto' column tracks

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 26 08:13:37 PST 2021


https://bugs.webkit.org/show_bug.cgi?id=191627

--- Comment #11 from Sergio Villar Senin <svillar at igalia.com> ---
Comment on attachment 421640
  --> https://bugs.webkit.org/attachment.cgi?id=421640
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=421640&action=review

> Source/WebCore/ChangeLog:8
> +        For grid items, grid container is the grid area it's located in rather than the containing block.

I think this should be reworded because it looks like there is one thing that is the containing block and another which is the grid area. For grid items the containing block is the grid area.

> Source/WebCore/rendering/RenderBox.cpp:2046
> +        return overridingContainingBlockContentLogicalWidth().valueOr(LayoutUnit());

Hmm if hasOverridingContainingBlockContentLogicalWidth() is true then we know that it has a value, then why do we need the valueOr() ?

> Source/WebCore/rendering/RenderBox.cpp:2057
> +    // FIXME: For grid items, the grid container is the grid area it's located in. We need to return whatever height value we get from overridingContainingBlockContentLogicalHeight() here, including WTF::nullopt.

Nit, "the grid container is" -> "the containing block is"

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210226/f2cacada/attachment-0001.htm>


More information about the webkit-unassigned mailing list