[Webkit-unassigned] [Bug 233383] AX: aria-owns in trees results duplicate rows, third level rows not being exposed
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Dec 8 16:32:42 PST 2021
https://bugs.webkit.org/show_bug.cgi?id=233383
--- Comment #19 from Tyler Wilcock <tyler_w at apple.com> ---
Comment on attachment 446445
--> https://bugs.webkit.org/attachment.cgi?id=446445
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=446445&action=review
> Source/WebCore/ChangeLog:13
> + * accessibility/AccessibilityObject.h:
Could you please include a summary of your changes in Source/WebCore/ChangeLog and LayoutTests/ChangeLog? What bug(s) does this patch fix, and how does it do it? This generally goes in between the "Reviewed by" and "Tests" sections.
> Source/WebCore/accessibility/AccessibilityObject.cpp:1888
> + parentPath.append(this);
I think I suggested parentPath in the first place, but maybe something like "ancestors" would be a better name?
> Source/WebCore/accessibility/AccessibilityObject.cpp:1910
> + downcast<AccessibilityObject>(*child).ariaTreeRows(result, parentPath);
Do we need is<> and downcast<> here? `child` is an AXCoreObject, which defines ariaTreeRows. I think we'd only need to downcast if AccessibilityObject defined ariaTreeRows and AXIsolatedObject didn't (these are the two direct subclasses of AXCoreObject).
So I think child->ariaTreeRows(result, ancestors); should work OK here.
> Source/WebCore/accessibility/AccessibilityObject.cpp:1934
> + downcast<AccessibilityObject>(*child).ariaTreeRows(result, parentPath);
Ditto.
> LayoutTests/accessibility/mac/treeitem-row-delegation-poorly-formed.html:39
> + description("This tests that a treeitem with a group that uses aria-owns will report its disclosed rows correctly.");
This description() is the same as the other test.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20211209/34b71977/attachment-0001.htm>
More information about the webkit-unassigned
mailing list