[Webkit-unassigned] [Bug 224538] [css-grid] last-baseline shouldn't affect baseline alignment

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 17 20:59:15 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=224538

Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |darin at apple.com
 Attachment #426201|review?                     |review+
              Flags|                            |

--- Comment #5 from Darin Adler <darin at apple.com> ---
Comment on attachment 426201
  --> https://bugs.webkit.org/attachment.cgi?id=426201
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=426201&action=review

> Source/WebCore/rendering/RenderGrid.cpp:1272
> +            if (isBaselineAlignmentForChild(*child) && !(alignSelfForChild(*child).position() == ItemPosition::LastBaseline || justifySelfForChild(*child).position() == ItemPosition::LastBaseline)) {

Is this the most elegant way to write it? I have trouble understanding the code. Also, consider the Demorgan’s Law equivalent:

    if (isBaselineAlignmentForChild(*child) && alignSelfForChild(*child).position() != ItemPosition::LastBaseline && justifySelfForChild(*child).position() != ItemPosition::LastBaseline) {

Maybe another named helper function like isBaselineAlignmentForChild could make the code more readable, although I don’t know what I’d name it.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210418/66273e4b/attachment.htm>


More information about the webkit-unassigned mailing list