[Webkit-unassigned] [Bug 214141] [WPE] lost touch events, wrong mousedown events

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 30 22:53:14 PDT 2020


https://bugs.webkit.org/show_bug.cgi?id=214141

--- Comment #12 from Marco Felsch <m.felsch at pengutronix.de> ---
Comment on attachment 405283
  --> https://bugs.webkit.org/attachment.cgi?id=405283
Fix touch based gesture handling

View in context: https://bugs.webkit.org/attachment.cgi?id=405283&action=review

>> Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:35
>> +WebKit::ScrollGestureController::TouchPoint ScrollGestureController::getMouseClickTouchId()
> 
> This is returning a “TouchPoint” instance so maybe something like
> “::lastMouseTouchPoint()” would be a better name for this method.

Yep, I will change that.

>> Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:40
>> +bool ScrollGestureController::pendingMouseClicks()
> 
> For methods that return booleans in WebKit we put a “has” or “is”
> prefix. Here I would rename this to “::hasPendingMouseClicks()”

Okay, Thanks for the input :)

>> Source/WebKit/UIProcess/API/wpe/ScrollGestureController.h:78
>> +    Vector<struct TouchPoint, 10> m_mouseClicks;
> 
> Just 'Vector<TouchPoint, 10> is enough. struct/class notation (beyond forward declarations and definitions) is ignored in the WebKit C++ coding style.

Arg.. Thanks for covering that :)

>> Source/WebKit/UIProcess/API/wpe/WPEView.cpp:178
>>              page.handleTouchEvent(touchEvent);
> 
> ScrollGestureController::handleEvent() returns a boolean, specifically true if the event was finally handled as a wheel event. If that's the case, should the original event still be handled as a touch event?

Yes we do and this is line is the main reason for this patch. Since the shortcut we don't handle it anymore but we need to.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20201001/5fe5533c/attachment.htm>


More information about the webkit-unassigned mailing list