[Webkit-unassigned] [Bug 214141] [WPE] lost touch events, wrong mousedown events

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 2 17:23:55 PDT 2020


https://bugs.webkit.org/show_bug.cgi?id=214141

--- Comment #10 from Adrian Perez <aperez at igalia.com> ---
Comment on attachment 405283
  --> https://bugs.webkit.org/attachment.cgi?id=405283
Fix touch based gesture handling

View in context: https://bugs.webkit.org/attachment.cgi?id=405283&action=review

Patch looks correct to me from the point of view of my limited
knowledge about how touch input is handled, so I would prefer if
someone else can also review this—I'll try and fish around another
reviewer ��️ 

I have only a couple of comments with minor code style issues,
please check the comments below.

> Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:35
> +WebKit::ScrollGestureController::TouchPoint ScrollGestureController::getMouseClickTouchId()

This is returning a “TouchPoint” instance so maybe something like
“::lastMouseTouchPoint()” would be a better name for this method.

> Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:40
> +bool ScrollGestureController::pendingMouseClicks()

For methods that return booleans in WebKit we put a “has” or “is”
prefix. Here I would rename this to “::hasPendingMouseClicks()”

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200903/a4110bf1/attachment-0001.htm>


More information about the webkit-unassigned mailing list