[Webkit-unassigned] [Bug 151030] ASSERTION FAILED: roundedIntPoint(LayoutPoint(rendererMappedResult)) == result in WebCore::RenderGeometryMap::mapToContainer

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 18 19:56:32 PST 2020


https://bugs.webkit.org/show_bug.cgi?id=151030

--- Comment #18 from Darin Adler <darin at apple.com> ---
Comment on attachment 391128
  --> https://bugs.webkit.org/attachment.cgi?id=391128
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=391128&action=review

>> Source/WebCore/rendering/RenderGeometryMap.cpp:112
>> +        ASSERT_IMPLIES(!m_accumulatedOffsetSaturated, roundedIntPoint(LayoutPoint(rendererMappedResult)) == result);
> 
> I think just adding the expression "m_accumulatedOffsetSaturated &&" to the assertion would be clearer than this use of ASSERT_IMPLIES. Maybe I’m biased, because I never heard of ASSERT_IMPLIES before today.

I guess Simon suggested using ASSERT_IMPLIES. But I still think this would be easier to read for me:

     ASSERT(m_accumulatedOffsetMightBeSaturated || roundedIntPoint(LayoutPoint(rendererMappedResult)) == result);

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20200219/749675bf/attachment.htm>


More information about the webkit-unassigned mailing list