[Webkit-unassigned] [Bug 203149] [GTK] Simplify the Input Method implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 23 00:35:58 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=203149

--- Comment #4 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to Adrian Perez from comment #3)
> Comment on attachment 381294 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=381294&action=review
> 
> It's definitely pleasant to see this code being simplified, thanks
> a lot. The patch looks good overall, with a couple of small comments,
> which you may want to address before landing :] 

Sure, thanks!

> > Source/WebCore/platform/PlatformKeyboardEvent.h:43
> >  #if PLATFORM(GTK)
> 
> This whole #if block can be removed, because there are no more uses
> of GdkEventKey left.

Indeed.

> > Source/WebKit/UIProcess/gtk/InputMethodFilter.h:42
> > +    enum class EventFakedForComposition {
> 
> You could use
> 
>   enum class EventFakedForComposition : bool { No, Yes};
> 
> as you have used elsewhere in the patch.
> 
> > Source/WebKit/UIProcess/gtk/InputMethodFilter.h:46
> > +    enum class EventHandledByInputMethod {
> 
> Ditto.

Yes, I didn't do that because I'm going to remove that enum in the next patch.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20191023/1a08e573/attachment.html>


More information about the webkit-unassigned mailing list