[Webkit-unassigned] [Bug 203149] [GTK] Simplify the Input Method implementation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 22 04:29:58 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=203149

Adrian Perez <aperez at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #381294|review?                     |review+
              Flags|                            |

--- Comment #3 from Adrian Perez <aperez at igalia.com> ---
Comment on attachment 381294
  --> https://bugs.webkit.org/attachment.cgi?id=381294
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=381294&action=review

It's definitely pleasant to see this code being simplified, thanks
a lot. The patch looks good overall, with a couple of small comments,
which you may want to address before landing :] 

> Source/WebCore/platform/PlatformKeyboardEvent.h:43
>  #if PLATFORM(GTK)

This whole #if block can be removed, because there are no more uses
of GdkEventKey left.

> Source/WebKit/UIProcess/gtk/InputMethodFilter.h:42
> +    enum class EventFakedForComposition {

You could use

  enum class EventFakedForComposition : bool { No, Yes};

as you have used elsewhere in the patch.

> Source/WebKit/UIProcess/gtk/InputMethodFilter.h:46
> +    enum class EventHandledByInputMethod {

Ditto.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20191022/b05d1e7d/attachment.html>


More information about the webkit-unassigned mailing list