[Webkit-unassigned] [Bug 199326] Allow Clients to Add Fields to the AutoFillContext Dictionary

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 28 11:17:38 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=199326

Brian Weinstein <bweinstein at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bweinstein at apple.com

--- Comment #4 from Brian Weinstein <bweinstein at apple.com> ---
Comment on attachment 373133
  --> https://bugs.webkit.org/attachment.cgi?id=373133
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=373133&action=review

>>> Source/WebKit/UIProcess/ios/WKContentViewInteraction.h:352
>>> +    NSDictionary *_sfAutoFillAdditionalContext;
>> 
>> Nit - just _autoFillAdditionalContext, or _additionalContextForAutoFill? (It’s a bit weird for SF-prefixed things to leak into WebKit)
> 
> This should also be a RetainPtr<NSDictionary>. We should probably clean this up too in the same places where we currently reset _focusRequiresStrongPasswordAssistance to NO.

I’d get rid of the sf prefix here, and just call this something like:

NSDictionary *_additionalContextForStrongPasswordAssistance;

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:5218
> +        _sfAutoFillAdditionalContext = @{ };

Nit: Our style is @{} (no space).

>> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:6644
>> +        return @{ @"_automaticPasswordKeyboard" : @YES, @"sfAutoFillAdditionalContext": _sfAutoFillAdditionalContext};
> 
> Nit - (same naming tweak for this key name)

I’d also get rid of the sf prefix in your string.

@“_strongPasswordAdditionalContext” seems more clear.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190628/d629b42f/attachment-0001.html>


More information about the webkit-unassigned mailing list