[Webkit-unassigned] [Bug 199326] Allow Clients to Add Fields to the AutoFillContext Dictionary

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 28 11:14:57 PDT 2019


https://bugs.webkit.org/show_bug.cgi?id=199326

--- Comment #2 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 373133
  --> https://bugs.webkit.org/attachment.cgi?id=373133
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=373133&action=review

Seems reasonable, with a few minor adjustments. It would also be nice to write an API test for this.

> Source/WebKit/ChangeLog:4
> +        https://bugs.webkit.org/show_bug.cgi?id=199326

Nit - please include a radar link below the bugzilla URL.

> Source/WebKit/UIProcess/API/Cocoa/_WKInputDelegate.h:58
> +- (NSDictionary *)_webViewAdditionalContextForStrongPasswordAssistance:(WKWebView *)webView;

This should have an availability macro (i.e. `WK_API_AVAILABLE(ios(WK_IOS_TBA))`) at the end.

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.h:352
> +    NSDictionary *_sfAutoFillAdditionalContext;

Nit - just _autoFillAdditionalContext, or _additionalContextForAutoFill? (It’s a bit weird for SF-prefixed things to leak into WebKit)

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:6644
> +        return @{ @"_automaticPasswordKeyboard" : @YES, @"sfAutoFillAdditionalContext": _sfAutoFillAdditionalContext};

Nit - (same naming tweak for this key name)

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190628/749bc843/attachment-0001.html>


More information about the webkit-unassigned mailing list