[Webkit-unassigned] [Bug 192030] Layout test should generate performance metrics

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 8 09:58:34 PST 2019


https://bugs.webkit.org/show_bug.cgi?id=192030

--- Comment #26 from Dean Johnson <dean_johnson at apple.com> ---
Comment on attachment 358550
  --> https://bugs.webkit.org/attachment.cgi?id=358550
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=358550&action=review

Looks good overall, just a few nits on style / naming.

> Tools/Scripts/webkitpy/layout_tests/layout_package/json_results_generator.py:122
> +def _add_test_perf_metric(path, time, tests, depth, target_depth):

Talked with Jonathan about target_depth as I was a bit confused by it. Could you rename it to depth_limit, which implies it is okay to exit before hitting target_depth?

> Tools/Scripts/webkitpy/layout_tests/layout_package/json_results_generator.py:124
> +    Breaks a test name into chunks by directory, and keep track the depth.

the depth -> of the depth.

Both lines may be able to be simplified to:
"Aggregate test time to result for a given test at a specified target_depth."

> Tools/Scripts/webkitpy/layout_tests/layout_package/json_results_generator.py:144
> +                    }}}

Is there a reason you expanded this block, but not the one below? We should try to be consistent in style here.

> Tools/Scripts/webkitpy/layout_tests/layout_package/json_results_generator.py:183
> +        # for now, we only sent two level of categories

sent -> send
level -> levels

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20190108/aad93520/attachment.html>


More information about the webkit-unassigned mailing list