[Webkit-unassigned] [Bug 188174] [WinCairo] Search terms are not saved for <input type="search">

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 18 09:49:14 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=188174

--- Comment #25 from Stephan Szabo <stephan.szabo at sony.com> ---
(In reply to Fujii Hironori from comment #23)
> Comment on attachment 352647 [details]
> Save windows search inputs to sqlite db
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=352647&action=review

Just updating for most of these, but a few comments.

> > Source/WebCore/platform/win/SearchPopupMenuWin.cpp:25
> > +#include <WebCore/FileSystem.h>
> 
> Do you use <WebCore/FileSystem.h> in this file?

Yes, I'm using pathByAppendingComponent and localUserSpecificStorageDirectory to generate the database file location.

> > Source/WebCore/platform/win/SearchPopupMenuWinDB.cpp:38
> > +    "    ind INTEGER NOT NULL,"
> 
> ind -> index
> https://webkit.org/code-style-guidelines/#names-full-words

Index is a reserved word in SQL, so we cannot name a column index (we could use "index" with the double quotes, but that becomes a bit of a mess). I'll change the name to position or something like that.

> > Source/WebCore/platform/win/SearchPopupMenuWinDB.h:63
> > +    HashMap<String, std::unique_ptr<SQLiteStatement>> m_statements;
> 
> Do you really need this HashMap? 
> https://trac.webkit.org/wiki/InvestigatingLeaksAndBloat

Since there's only a few specific statements, we can probably do without it as you mention. If this somehow ended up with a ton of statements it might be a problem, but that seems unlikely.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20181018/7c82c8ab/attachment-0001.html>


More information about the webkit-unassigned mailing list