[Webkit-unassigned] [Bug 185611] [GTK][WPE]: Avoid trying to getenv with an unset varname

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jun 15 08:02:49 PDT 2018


Thibault Saunier <tsaunier at gnome.org> changed:

           What    |Removed                     |Added
 Attachment #341289|0                           |1
        is obsolete|                            |
 Attachment #342812|                            |review?, commit-queue?
              Flags|                            |

--- Comment #33 from Thibault Saunier <tsaunier at gnome.org> ---
Created attachment 342812

  --> https://bugs.webkit.org/attachment.cgi?id=342812&action=review


(In reply to Chris Dumez from comment #32)
> I think we should either:
> - Not add new enum value and just swap the instructions here.
> or (if we want to provide some validation that the processType gets set):
> - Rename None to Unset (or Invalid) & ASSERT in
> ChildProcessProxy::getLaunchOptions() that processType is not Unset/Invalid.

I decided to keep it simple and just swap the lines.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180615/856077ae/attachment.html>

More information about the webkit-unassigned mailing list