[Webkit-unassigned] [Bug 185611] [GTK][WPE]: Avoid trying to getenv with an unset varname

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 14 17:38:26 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=185611

--- Comment #32 from Chris Dumez <cdumez at apple.com> ---
Comment on attachment 341289
  --> https://bugs.webkit.org/attachment.cgi?id=341289
Update to avoid `enumeration value 'None' not handled in switch` issues in Apple's code.

View in context: https://bugs.webkit.org/attachment.cgi?id=341289&action=review

>> Source/WebKit/UIProcess/Plugins/PluginProcessProxy.cpp:92
>> +    ChildProcessProxy::getLaunchOptions(launchOptions);
> 
> Yes, we definitely need to swap the 2 instructions here. Why isn't this enough? Why do we need a new ProcessType::None enum value?

None is not a valid process Type and we should always have a valid process type I believe.

I think we should either:
- Not add new enum value and just swap the instructions here.
or (if we want to provide some validation that the processType gets set):
- Rename None to Unset (or Invalid) & ASSERT in ChildProcessProxy::getLaunchOptions() that processType is not Unset/Invalid.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180615/181e6824/attachment-0001.html>


More information about the webkit-unassigned mailing list