[Webkit-unassigned] [Bug 189114] Long press on picture/link show menu obscured by keyboard

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 29 17:44:48 PDT 2018


https://bugs.webkit.org/show_bug.cgi?id=189114

Megan Gardner <megan_gardner at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #348447|review?                     |review+
              Flags|                            |

--- Comment #2 from Megan Gardner <megan_gardner at apple.com> ---
Comment on attachment 348447
  --> https://bugs.webkit.org/attachment.cgi?id=348447
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=348447&action=review

r=me, with comments.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:373
> +        CGRect visibleRect = CGRectNull;

See associated next comment.
I think this should be view.window.bounds (or equivalent) not CGRectNull.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:402
>  {

Probably rename this to something better if we make the associated changes.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:411
> +        visibleRect = view.window.bounds;

Could we move this logic to the calling function? I don't like having to do this compare here, if we just set the visible rect to the default before we even call into here, then we can make this cleaner.

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:414
> +

remove whitespace

> Source/WebKit/UIProcess/ios/WKActionSheetAssistant.mm:549
> +    CGRect visibleRect = CGRectNull;

Same as above. Should be view.window.bounds

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20180830/bac797d8/attachment.html>


More information about the webkit-unassigned mailing list