[Webkit-unassigned] [Bug 177225] Update syncing script to be able to build binary for commit set with owned commits.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Sep 27 00:58:30 PDT 2017
https://bugs.webkit.org/show_bug.cgi?id=177225
--- Comment #5 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 321808
--> https://bugs.webkit.org/attachment.cgi?id=321808
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=321808&action=review
> Websites/perf.webkit.org/public/v3/models/commit-set.js:72
> + topLevelRepositoriesSortedByNamePreferringOnesWithURL() {
We can just call this topLevelRepositories() instead.
Nit: { should be on the next line.
> Websites/perf.webkit.org/public/v3/models/commit-set.js:223
> + topLevelRepositoriesSortedByNamePreferringOnesWithURL() {
Ditto.
> Websites/perf.webkit.org/tools/js/buildbot-syncer.js:476
> + case 'ownedRevisions':
> + return {type, ownerRepositories: value.map(resolveRepository)};
I don't think we need or should have a list of owner repositories.
For simplicity, just support a single owner instead.
e.g. we'd just specify iOS or macOS in our internal dashboard.
> Websites/perf.webkit.org/unit-tests/buildbot-syncer-tests.js:1007
> + 'checkbox': {'ifRepositorySet': {'value': 'build-webkit', 'repositoriesToCheck': ['WebKit']}},
There's no need to have two nested dictionaries like this.
We should relax the restriction in _parseRepositoryGroupPropertyTemplate that option's dictionary can only contain a single key,
and specify value & repositoriesToCheck in the outer dictionary as in:
{'fRepositorySet': ['WebKit'], 'value': 'build-webkit'}
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170927/69b86a5b/attachment.html>
More information about the webkit-unassigned
mailing list