[Webkit-unassigned] [Bug 171602] REGRESSION(r215686): Incremental reads from SharedBuffer are wrong after r215686

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 3 23:00:39 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=171602

--- Comment #3 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to Alexey Proskuryakov from comment #2)
> Comment on attachment 308899 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=308899&action=review
> 
> > Source/WebCore/loader/TextTrackLoader.cpp:103
> > -        m_cueParser->parseBytes(segment->data() + bytesToSkip, segment->size() - bytesToSkip);
> > +        auto bytesToUse = segment->size() - bytesToSkip;
> > +        m_cueParser->parseBytes(segment->data() + bytesToSkip, bytesToUse);
> >          bytesToSkip = 0;
> > -        m_parseOffset += segment->size();
> > +        m_parseOffset += bytesToUse;
> 
> There doesn't seem to be a test for this part of the patch. What does this
> fix?

I don't even know what TextTrackLoader is, but the pattern to read the data is exactly the same as in PNGEncoder, so this will fail the same way in case of incremental reads where bytesToSkip != 0 in any of the reads. Alex said he was going to add API to SharedBuffer to make it easier to read this way, so this and PNGEncoder will be updated too eventually.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170504/7ceaa8c5/attachment-0001.html>


More information about the webkit-unassigned mailing list