[Webkit-unassigned] [Bug 169143] New: webkitpy.common.checkout.scm.git.py should be renamed to gitsvn
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Mar 3 12:42:34 PST 2017
https://bugs.webkit.org/show_bug.cgi?id=169143
Bug ID: 169143
Summary: webkitpy.common.checkout.scm.git.py should be renamed
to gitsvn
Classification: Unclassified
Product: WebKit
Version: Other
Hardware: Other
OS: Other
Status: NEW
Severity: Enhancement
Priority: P2
Component: Tools / Tests
Assignee: webkit-unassigned at lists.webkit.org
Reporter: kocsen_chung at apple.com
CC: lforschler at apple.com
Inside of webkitpy/common/checkout/scm/
The Git class (git.py) inherits from SCM class (scm.py) _and_ SVNRepository class (svn.py).
This can be misleading since many of the implemented functions on git.py are really implementations for a git-svn repository.
Examples of this include:
- git.svn_url()
- git.svn_commit_log()
- git.svn_blame()
- git.svn_revision()
And a heavily misleading one:
- git.push_local_commits_to_server() => Uses git svn dcommit
It seems that this Git class is really an abstraction around git-svn commands and should be refactored accordingly.
This bug may also involve changing the abstract functions declared on scm.py. (i.e scm.svn_revision() is not an appropriate abstraction of an scm. Instead, something like svn.latest_revision() may be more appropriate. It would, then, be up to sublcasses git.py / svn.py to implement acoordingly.)
This bug was inspired after I wanted to use the Git class to fetch the latest SHA/Hash and found it didn't exist under git.py. The closest thing was git.svn_revision() which seemed out of place.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170303/c0d8bafa/attachment.html>
More information about the webkit-unassigned
mailing list