<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>Bug ID</th>
<td><a class="bz_bug_link
bz_status_NEW "
title="NEW - webkitpy.common.checkout.scm.git.py should be renamed to gitsvn"
href="https://bugs.webkit.org/show_bug.cgi?id=169143">169143</a>
</td>
</tr>
<tr>
<th>Summary</th>
<td>webkitpy.common.checkout.scm.git.py should be renamed to gitsvn
</td>
</tr>
<tr>
<th>Classification</th>
<td>Unclassified
</td>
</tr>
<tr>
<th>Product</th>
<td>WebKit
</td>
</tr>
<tr>
<th>Version</th>
<td>Other
</td>
</tr>
<tr>
<th>Hardware</th>
<td>Other
</td>
</tr>
<tr>
<th>OS</th>
<td>Other
</td>
</tr>
<tr>
<th>Status</th>
<td>NEW
</td>
</tr>
<tr>
<th>Severity</th>
<td>Enhancement
</td>
</tr>
<tr>
<th>Priority</th>
<td>P2
</td>
</tr>
<tr>
<th>Component</th>
<td>Tools / Tests
</td>
</tr>
<tr>
<th>Assignee</th>
<td>webkit-unassigned@lists.webkit.org
</td>
</tr>
<tr>
<th>Reporter</th>
<td>kocsen_chung@apple.com
</td>
</tr>
<tr>
<th>CC</th>
<td>lforschler@apple.com
</td>
</tr></table>
<p>
<div>
<pre>Inside of webkitpy/common/checkout/scm/
The Git class (git.py) inherits from SCM class (scm.py) _and_ SVNRepository class (svn.py).
This can be misleading since many of the implemented functions on git.py are really implementations for a git-svn repository.
Examples of this include:
- git.svn_url()
- git.svn_commit_log()
- git.svn_blame()
- git.svn_revision()
And a heavily misleading one:
- git.push_local_commits_to_server() => Uses git svn dcommit
It seems that this Git class is really an abstraction around git-svn commands and should be refactored accordingly.
This bug may also involve changing the abstract functions declared on scm.py. (i.e scm.svn_revision() is not an appropriate abstraction of an scm. Instead, something like svn.latest_revision() may be more appropriate. It would, then, be up to sublcasses git.py / svn.py to implement acoordingly.)
This bug was inspired after I wanted to use the Git class to fetch the latest SHA/Hash and found it didn't exist under git.py. The closest thing was git.svn_revision() which seemed out of place.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>