[Webkit-unassigned] [Bug 174331] Add setup script for Web Driver part of Benchmark Runner script

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 20 17:06:41 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=174331

--- Comment #16 from dewei_zhu at apple.com ---
Comment on attachment 316011
  --> https://bugs.webkit.org/attachment.cgi?id=316011
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=316011&action=review

> Tools/Scripts/webkitpy/thirdparty/__init__.py:226
> +    return (chrome_os, firefox_os)

Using namedtuple would improve the readability of this code and get rid of the assumption we made on the indices of the return value.
DriverFilenameForBrowser = namedtuple('DriverFilenameForBrowser', ['chrome', 'firefox'])
return DriverFilenameForBrowser((chrome_os, firefox_os))
And update the use of this function's return value accordingly.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170721/20109fee/attachment.html>


More information about the webkit-unassigned mailing list