[Webkit-unassigned] [Bug 171450] Add a new function for getting the Git hash for a pure git directory.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 28 14:38:39 PDT 2017


https://bugs.webkit.org/show_bug.cgi?id=171450

--- Comment #2 from Matthew Hanson <matthew_hanson at apple.com> ---
Comment on attachment 308595
  --> https://bugs.webkit.org/attachment.cgi?id=308595
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=308595&action=review

Perhaps we should warn the user if the directory is not a Git directory, since that is likely indicative of a mistake on the part of the caller.

This is a great addition; The semicolon needs to be addressed and I'd like to see a warning when this function is called on non-Git repos.

> Tools/Scripts/VCSUtils.pm:451
> +    my $revision;

I know that the variable name $revision is consistent with the other functions of this ilk, but you might consider calling it $commit or $hash to match the name of your function.

> Tools/Scripts/VCSUtils.pm:454
> +        warn "$directory is a pure git repo.";

Is this debugging code?

> Tools/Scripts/VCSUtils.pm:458
> +        chomp($revision)

Missing semicolon.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170428/0df93acb/attachment.html>


More information about the webkit-unassigned mailing list