[Webkit-unassigned] [Bug 170693] Adopt AVKit name change from AVFunctionBar* to AVTouchBar*

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 10 16:58:18 PDT 2017


--- Comment #3 from Beth Dakin <bdakin at apple.com> ---
(In reply to Tim Horton from comment #2)
> Comment on attachment 306741 [details]
> Patch
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=306741&action=review
> > Source/WebCore/platform/spi/cocoa/AVKitSPI.h:161
> > +typedef AVTouchBarMediaSelectionOption WKAVTouchBarMediaSelectionOption;
> Though I think it was my suggestion to do the WK-, now I wonder if it would
> be better to just typedef to the new names on the old OS, and use the new
> names everywhere? We know they won't magically appear in the old SDK.

Oh yeah, that's a pretty good idea. I'm going to attach a new patch that doesn't do that yet just to see if I can get the bots green.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20170410/fb0eeb25/attachment.html>

More information about the webkit-unassigned mailing list