[Webkit-unassigned] [Bug 163161] Extend event stream to include interpolated events and add a force press test that uses that interpolation

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 7 19:19:51 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=163161

--- Comment #4 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 291001
  --> https://bugs.webkit.org/attachment.cgi?id=291001
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=291001&action=review

> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:131
> +static pressureInterpolationFunction interplations[] = {

interplations[] => interpolations[]?

> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:233
> +    if ([string isEqualToString:HIDEventInterpolationTypeLinear])

Can we remove this [string isEqualToString:HIDEventInterpolationTypeLinear] check here?

> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:975
> +    InterpolationType interpType = interpolationFromString(interpolationsDictionary[HIDEventInterpolateKey]);

Nit - I think we generally don't abbreviate variable names per style guidelines (i.e. it should be interpolationType here).

> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:982
> +    NSTimeInterval time = startTime;

Should this be starting at startTime + timeStep, or just startTime? From the while loop, it seems like we'll stop before computing the touch dictionary corresponding to endTime, so it seems a bit strange we're including startTime's touch dictionary in here.

> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:989
> +        double t = (time - startTime) / (endTime - startTime);

Nit - we can pull (endTime - startTime) out of the while loop. Could we also name this variable something like 'progress'?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161008/e9139468/attachment-0001.html>


More information about the webkit-unassigned mailing list