[Webkit-unassigned] [Bug 164454] The GC should be optionally concurrent

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Nov 5 11:40:52 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=164454

--- Comment #1 from Filip Pizlo <fpizlo at apple.com> ---
There are two things that definitely need to get done for this to be correct:

1) Separate the SlotVisitor used by the mutator's write barrier from the SlotVisitor used by the collector thread.  It's not super clear if the write barrier should even use a SlotVisitor, but whatever - the MarkStackArray probably has everything we need to efficiently transfer the entire contents of the mutator SlotVisitor into the collector SlotVisitor.

2) We need to stopAllocating/resumeAllocating.  It's tempting to think that this should be done by the mutator, but that's actually just complicating things.  It should be the collector's responsibility, and I think that these methods should be called from stopTheWorld/resumeTheWorld.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161105/49066516/attachment.html>


More information about the webkit-unassigned mailing list