[Webkit-unassigned] [Bug 149056] [GTK] Spellchecker rejects word when adding a period or colon character if there is no trailing space before the next word

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 3 08:53:20 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=149056

Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #272757|review?, commit-queue?      |review-, commit-queue-
              Flags|                            |

--- Comment #21 from Darin Adler <darin at apple.com> ---
Comment on attachment 272757
  --> https://bugs.webkit.org/attachment.cgi?id=272757
Expand newAdjacentwords selection from its boundaries

View in context: https://bugs.webkit.org/attachment.cgi?id=272757&action=review

A bug fix like this needs a regression test to help make clear exactly what it changes and fixes. Any reason we don’t have one here?

> Source/WebCore/ChangeLog:3
> +        [GTK] Spellchecker rejects word when adding a period or colon character if there is no trailing space before the next word

This is not a GTK-specific patch and should not have the GTK prefix on it.

> Source/WebCore/editing/Editor.cpp:3407
> +            // being conservative allow to fix that and doesn't seem to disturb any other behavior.

"allow to fix that" is not the right phrase here

"fixes that" would be correct grammar

> Source/WebCore/editing/VisibleSelection.h:88
> +    int getLength() const { return end().computeOffsetInContainerNode() - start().computeOffsetInContainerNode(); }

This naming is not consistent with WebKit coding style. We don’t use get in the name of functions like this.

This code is wrong. It will give an incorrect value any time the start and end positions are not in the same container node, or when they are in the same container node, but it is not a text node.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160303/2ed2fea5/attachment.html>


More information about the webkit-unassigned mailing list