[Webkit-unassigned] [Bug 158832] WebRTC: Replace RTCPeerConnection custom constructor with a JS built-in constructor

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 20 14:47:32 PDT 2016


https://bugs.webkit.org/show_bug.cgi?id=158832

--- Comment #6 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 281665
  --> https://bugs.webkit.org/attachment.cgi?id=281665
Updated patch

View in context: https://bugs.webkit.org/attachment.cgi?id=281665&action=review

> Source/WebCore/Modules/mediastream/RTCPeerConnection.cpp:83
> +    Document& document = downcast<Document>(*scriptExecutionContext());

It might be better to use CallWith=Document in the IDL to pass Document as parameter to the IDL

> Source/WebCore/Modules/mediastream/RTCPeerConnection.h:66
> +    void initializeWith(const Dictionary& rtcConfiguration, ExceptionCode&);

Is "rtcConfiguration" needed?

> Source/WebCore/Modules/mediastream/RTCPeerConnection.js:44
> +        this. at initializeWith(configuration);

I am not quite sure but can we find a better handling of errors than catching-and-rethrowing?
Would it be more readable to make initializeWith return a status code instead?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160620/d5adb838/attachment.html>


More information about the webkit-unassigned mailing list