<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - WebRTC: Replace RTCPeerConnection custom constructor with a JS built-in constructor"
href="https://bugs.webkit.org/show_bug.cgi?id=158832#c6">Comment # 6</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - WebRTC: Replace RTCPeerConnection custom constructor with a JS built-in constructor"
href="https://bugs.webkit.org/show_bug.cgi?id=158832">bug 158832</a>
from <span class="vcard"><a class="email" href="mailto:youennf@gmail.com" title="youenn fablet <youennf@gmail.com>"> <span class="fn">youenn fablet</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=281665&action=diff" name="attach_281665" title="Updated patch">attachment 281665</a> <a href="attachment.cgi?id=281665&action=edit" title="Updated patch">[details]</a></span>
Updated patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=281665&action=review">https://bugs.webkit.org/attachment.cgi?id=281665&action=review</a>
<span class="quote">> Source/WebCore/Modules/mediastream/RTCPeerConnection.cpp:83
> + Document& document = downcast<Document>(*scriptExecutionContext());</span >
It might be better to use CallWith=Document in the IDL to pass Document as parameter to the IDL
<span class="quote">> Source/WebCore/Modules/mediastream/RTCPeerConnection.h:66
> + void initializeWith(const Dictionary& rtcConfiguration, ExceptionCode&);</span >
Is "rtcConfiguration" needed?
<span class="quote">> Source/WebCore/Modules/mediastream/RTCPeerConnection.js:44
> + this.@initializeWith(configuration);</span >
I am not quite sure but can we find a better handling of errors than catching-and-rethrowing?
Would it be more readable to make initializeWith return a status code instead?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>