[Webkit-unassigned] [Bug 158364] AX: WKWebView should have API to prevent pinch-to-zoom always being allowed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 8 15:48:45 PDT 2016


--- Comment #9 from Anders Carlsson <andersca at apple.com> ---
(In reply to comment #8)
> Comment on attachment 280478 [details]
> patch
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=280478&action=review
> > Source/WebKit2/UIProcess/API/Cocoa/WKWebView.h:248
> > + at property (nonatomic) BOOL alwaysUserScalable WK_AVAILABLE(NA, 10_0);
> The naming of this API is surprising (and the fact that it's API at all, to
> start out with). I cc'd andersca for thoughts.
> >>>> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:2214
> >>>> +#if __IPHONE_OS_VERSION_MIN_REQUIRED >= 100000
> >>> 
> >>> Is all the iOS versioning required? This code will never run on an older device right
> >> 
> >> Because we set the property WK_AVAILABLE(NA, 10_0), do you think we should remove that as well?

New APIs should be versioned. We use WK_IOS_TBA for new APIs. I don't like the name.

> > 
> > It seems like that should be kept there so people compiling against different versions know whats there or not, but internally the versioning seems uncessary to me. Maybe someone else has a different opinion
> The versioning should definitely not be here, there's no reason for it and
> it absolutely can be run on different versions (and should be usable and
> testable there).

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160608/94ac7bae/attachment.html>

More information about the webkit-unassigned mailing list