<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - AX: WKWebView should have API to prevent pinch-to-zoom always being allowed"
href="https://bugs.webkit.org/show_bug.cgi?id=158364#c9">Comment # 9</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - AX: WKWebView should have API to prevent pinch-to-zoom always being allowed"
href="https://bugs.webkit.org/show_bug.cgi?id=158364">bug 158364</a>
from <span class="vcard"><a class="email" href="mailto:andersca@apple.com" title="Anders Carlsson <andersca@apple.com>"> <span class="fn">Anders Carlsson</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=158364#c8">comment #8</a>)
<span class="quote">> Comment on <span class=""><a href="attachment.cgi?id=280478&action=diff" name="attach_280478" title="patch">attachment 280478</a> <a href="attachment.cgi?id=280478&action=edit" title="patch">[details]</a></span>
> patch
>
> View in context:
> <a href="https://bugs.webkit.org/attachment.cgi?id=280478&action=review">https://bugs.webkit.org/attachment.cgi?id=280478&action=review</a>
>
> > Source/WebKit2/UIProcess/API/Cocoa/WKWebView.h:248
> > +@property (nonatomic) BOOL alwaysUserScalable WK_AVAILABLE(NA, 10_0);
>
> The naming of this API is surprising (and the fact that it's API at all, to
> start out with). I cc'd andersca for thoughts.
>
> >>>> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:2214
> >>>> +#if __IPHONE_OS_VERSION_MIN_REQUIRED >= 100000
> >>>
> >>> Is all the iOS versioning required? This code will never run on an older device right
> >>
> >> Because we set the property WK_AVAILABLE(NA, 10_0), do you think we should remove that as well?</span >
New APIs should be versioned. We use WK_IOS_TBA for new APIs. I don't like the name.
<span class="quote">> >
> > It seems like that should be kept there so people compiling against different versions know whats there or not, but internally the versioning seems uncessary to me. Maybe someone else has a different opinion
>
> The versioning should definitely not be here, there's no reason for it and
> it absolutely can be run on different versions (and should be usable and
> testable there).</span ></pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>