[Webkit-unassigned] [Bug 159552] [GStreamer][GL] crash within triggerRepaint
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jul 12 23:45:52 PDT 2016
https://bugs.webkit.org/show_bug.cgi?id=159552
--- Comment #9 from Carlos Garcia Campos <cgarcia at igalia.com> ---
(In reply to comment #6)
> (In reply to comment #4)
> > if (isMainThread())
> > m_player->sizeChanged();
> > else {
> > auto weakThis = player.createWeakPtr();
> > RunLoop::main().dispatch([weakThis]) {
> > if (weakThis)
> > weakThis->m_player->sizeChanged();
> > });
> > }
>
> I understand the concerns about reducing performance but if there isn't we
> should create a function to do something like:
This is not about performance at all, this is to a void a use after free.
> {
> auto weakThis = player.createWeakPtr();
> RunLoop::main().runNowIfMainThreadOrdispatch([weakThis]) {
> if (weakThis)
> weakThis->m_player->sizeChanged();
> });
> }
>
> Otherwise I think we are creating these code structures and IMHO it makes
> code hard to read.
That's what the MainThreadNotifier is for, I already agreed with philn to use it.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160713/a2fcebe7/attachment-0001.html>
More information about the webkit-unassigned
mailing list