[Webkit-unassigned] [Bug 152888] [GTK] Cleanup RenderThemeGtk

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 8 08:23:26 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=152888

Michael Catanzaro <mcatanzaro at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #268539|review?                     |review+
              Flags|                            |

--- Comment #3 from Michael Catanzaro <mcatanzaro at igalia.com> ---
Comment on attachment 268539
  --> https://bugs.webkit.org/attachment.cgi?id=268539
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=268539&action=review

Excellent patch; this worked quite well. Thanks for taking the time to work on this. Please watch the bots when this lands.

Looks like this also fixes bug #151502. Please close that when this lands.

Somewhat related: look at bug #152273.

> Source/WebCore/rendering/RenderThemeGtk.cpp:140
> +enum RenderThemePart {

I prefer to almost always use enum class in new code, both for safety, and also because I think it's more readable to use the RenderThemePart:: scope everywhere. But if you prefer to avoid the scoping, this is fine.

> Source/WebCore/rendering/RenderThemeGtk.cpp:379
> +    gtk_style_context_set_state(context.get(), gtk_widget_path_iter_get_state(path.get(), -1));

What's this for? Looks like a mistake. You have not set any state on the GtkWidgetPath. If this code actually does anything, then I would suspect that context might be inheriting its state from its parent... in which case it would be clearer to pass GTK_STATE_FLAGS_NONE.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160108/7aeb8494/attachment.html>


More information about the webkit-unassigned mailing list