[Webkit-unassigned] [Bug 152786] Factor free standing tree style resolve functions into a class

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 6 10:34:54 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=152786

--- Comment #8 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 268367
  --> https://bugs.webkit.org/attachment.cgi?id=268367
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=268367&action=review

> Source/WebCore/style/StyleResolveTree.h:50
> +class TreeResolver {

It's odd that the filename and class name don't match. It think you should rename one of them.

> Source/WebCore/style/StyleResolveTree.h:59
> +    void resolveShadowTree(Change, RenderStyle& inheritedStyle);

Unclear from the signature whether inheritedStyle is 'in' or 'out'.

> Source/WebCore/style/StyleResolveTree.h:61
> +    Ref<RenderStyle> styleForElement(Element&, RenderStyle& inheritedStyle);

Ditto. Can inheritedStyle be const? Can Element& be const? Same for most of the other functions.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20160106/000468a4/attachment.html>


More information about the webkit-unassigned mailing list