[Webkit-unassigned] [Bug 165768] New: Rename BytecodeGenerator's m_symbolTableStack to m_lexicalScopeStack.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 12 12:49:21 PST 2016


https://bugs.webkit.org/show_bug.cgi?id=165768

            Bug ID: 165768
           Summary: Rename BytecodeGenerator's m_symbolTableStack to
                    m_lexicalScopeStack.
    Classification: Unclassified
           Product: WebKit
           Version: WebKit Local Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

The lexical scope in "m_lexicalScopeStack" here refers to a pair of { } in the source code that bounds the scope of variables.

There are 4 places in the code where we call m_symbolTableStack.append() to append a new stack entry.  In only 3 of the 4 cases, a symbol table is provided in the new stack entry.  In all 4 cases, a scope register is provided in the new stack entry.

Also, 3 of the 4 functions that appends an entry to this stack are named:
1. initializeVarLexicalEnvironment()
2. pushLexicalScopeInternal()
3. emitPushWithScope()

The 4th function is the BytecodeGenerator constructor where it pushes the scope for a module environment.

Based on these details, m_lexicalScopeStack is a better name for this stack than m_symbolTableStack.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20161212/81d6ef1c/attachment.html>


More information about the webkit-unassigned mailing list