[Webkit-unassigned] [Bug 149676] Implement keyboard event sending for iOS in WebKitTestRunner
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Sep 30 16:37:52 PDT 2015
https://bugs.webkit.org/show_bug.cgi?id=149676
--- Comment #6 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 262196
--> https://bugs.webkit.org/attachment.cgi?id=262196
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=262196&action=review
>> Tools/WebKitTestRunner/UIScriptContext/Bindings/UIScriptController.idl:38
>> + void typeCharacter(DOMString character, object callback);
>
> This should be named to make it clear whether it's a hardware keyboard event, or a software keyboard event.
Renaming to typeCharacterUsingHardwareKeyboard
>> Tools/WebKitTestRunner/UIScriptContext/UIScriptController.cpp:103
>> +void typeCharacter(JSStringRef, JSValueRef)
>
> UIScriptController::
Fixed.
>> Tools/WebKitTestRunner/UIScriptContext/UIScriptController.h:62
>> +#endif
>
> I've avoided #idfefs here, and just stubbed the functions out for non-iOS.
Got it. I'll stub out the functions for non-iOS.
>> Tools/WebKitTestRunner/cocoa/TestRunnerWKWebView.mm:66
>> + _keyboardMayAcceptKeyInput = NO;
>
> The name of this property is confusing. Is it really _keyboardIsVisible?
Yes, keyboardIsVisible would be a more accurate name. I'll change it to that.
>> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:139
>> + kIOHIDEventOptionNone)];
>
> You're leaking the event.
Good catch. Adding temp RetainPtr so the event is released after sending.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150930/eb93b603/attachment-0001.html>
More information about the webkit-unassigned
mailing list