<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement keyboard event sending for iOS in WebKitTestRunner"
href="https://bugs.webkit.org/show_bug.cgi?id=149676#c6">Comment # 6</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement keyboard event sending for iOS in WebKitTestRunner"
href="https://bugs.webkit.org/show_bug.cgi?id=149676">bug 149676</a>
from <span class="vcard"><a class="email" href="mailto:wenson_hsieh@apple.com" title="Wenson Hsieh <wenson_hsieh@apple.com>"> <span class="fn">Wenson Hsieh</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=262196&action=diff" name="attach_262196" title="Patch">attachment 262196</a> <a href="attachment.cgi?id=262196&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=262196&action=review">https://bugs.webkit.org/attachment.cgi?id=262196&action=review</a>
<span class="quote">>> Tools/WebKitTestRunner/UIScriptContext/Bindings/UIScriptController.idl:38
>> + void typeCharacter(DOMString character, object callback);
>
> This should be named to make it clear whether it's a hardware keyboard event, or a software keyboard event.</span >
Renaming to typeCharacterUsingHardwareKeyboard
<span class="quote">>> Tools/WebKitTestRunner/UIScriptContext/UIScriptController.cpp:103
>> +void typeCharacter(JSStringRef, JSValueRef)
>
> UIScriptController::</span >
Fixed.
<span class="quote">>> Tools/WebKitTestRunner/UIScriptContext/UIScriptController.h:62
>> +#endif
>
> I've avoided #idfefs here, and just stubbed the functions out for non-iOS.</span >
Got it. I'll stub out the functions for non-iOS.
<span class="quote">>> Tools/WebKitTestRunner/cocoa/TestRunnerWKWebView.mm:66
>> + _keyboardMayAcceptKeyInput = NO;
>
> The name of this property is confusing. Is it really _keyboardIsVisible?</span >
Yes, keyboardIsVisible would be a more accurate name. I'll change it to that.
<span class="quote">>> Tools/WebKitTestRunner/ios/HIDEventGenerator.mm:139
>> + kIOHIDEventOptionNone)];
>
> You're leaking the event.</span >
Good catch. Adding temp RetainPtr so the event is released after sending.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>