[Webkit-unassigned] [Bug 149567] Expose a WKWebView API for allowing programmatic focus to trigger node assistance

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 28 09:08:30 PDT 2015


https://bugs.webkit.org/show_bug.cgi?id=149567

--- Comment #7 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 261960
  --> https://bugs.webkit.org/attachment.cgi?id=261960
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261960&action=review

>> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.h:248
>> + at property (nonatomic) BOOL canAssistOnProgrammaticFocus;
> 
> This API declaration is missing availability information.
> 
> It’s surprising that this API uses the term “assist”. Is this something that’s used anywhere else in WebKit or UIKit API?
> 
> Have you considered other ways to expose this ability to clients? For example, calling the delegate when an element is focused and asking it to make a decision seems like it would afford more flexibility.

Just to make sure -- would I add availability information via something like WK_AVAILABLE(10_12, 10_0)?

Good point, it looks like assistance is not really mentioned in the WebKit API and in UIKit it refers to accessibility-related things rather than bringing up the keyboard. Maybe I could rephrase it to be something like "A Boolean value indicating whether programmatic focus on an element is allowed to display the keyboard." Also, now that I'm aware keyboardDisplayRequiresUserAction exists for UIWebView, I think we should rename this flag to keyboardDisplayRequiresUserAction for better consistency.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.webkit.org/pipermail/webkit-unassigned/attachments/20150928/ac524b3c/attachment.html>


More information about the webkit-unassigned mailing list